Public Folder Migration from Exchange 2003 to 2007/2010

Use PFADMIN or make the changes manual:

1) Check the settings on each Public Folder (Always Replicate, Urgent)

2) Remove all LIMITS Like SIZE Current concurent Connections on SMTP and Public Folder

3) Make sure you change Maintenance on everything to ALWAYS reunning and 24/4 (Change afterwards back)

You can move then Public Folder in 2003 SP2 via the GUI(Console ESM) or you the Scripts under follwing path:

"C:\Program Files\Microsoft\Exchange Server\V14\Scripts"
.\AddReplicaToPFRecursive.ps1 -server "SBSERVER2" -TopPublicFolder "\" -ServerToAdd "SBSERVER2"

Update-PublicFolderHierarchy -Server "SBSERVER2"
.\MoveAllReplicas.ps1 -Server "SBSERVER1" -NewServer "SBSERVER2"

Additional Cmdlets

  • To view a list of the replicas in the public folder hierarchy: Get-PublicFolder -recurse |fl name,replicas
  • For System Folders: Get-PublicFolder -recurse \non_ipm_subtree |fl name, replicas
  • To compare content replicated between the source and destination servers: Get-PublicFolderStatistics 





Issue description: Public folder replication issue from exchange 2003 to exchange 2007

Collect info:

1.       Confirm the version and SP of exchange, are they exchange 2003 SP2 and exchange 2007 SP1?

2.       Please check if there’s any related error or warning info about public folder replication in the both servers


1.       Did the hierarchy and content not replicate all from exchange 2003 [e2k3] to 2007 [e2k7] at all?

·         Use PFDavAdmin to check the public folders’ contents

·         Use MFCMAPI to check which server outlook is connecting to

a.    Launch it on one of the users

b.    “Session” menu->choose “Logon and Display Store Table”->choose his profile in jumped window

c.    On the top-pane, double-click user’s public folder and go to next window

d.      Click on the root folder, and then search for “PR_REPLICA_SERVER” property on the right-pane. Check which server name is listed in there

2.       Also, please rise diagnose level to “Maximum” to monitor the issue, it will generate the incoming and outgoing loggings on the application log for both of servers, they will able to tell us what’s going on:

·         E2k3: logging on Replication Incoming and Replication Outgoing to “Maximum” in ESM

·         E2k7: Use “Set-EventLogLevel” to set "MSExchangeIS\9001 Public\Replication Incoming Messages" and "MSExchangeIS\9001 Public\Replication Outgoing Messages" to the Expert level in EMS

·         Then try to remove and add the e2k7 to replica list again to generate the log

Please check the “Troubleshooting the Replication of New Changes” section of “public folder replication troubleshooting


TRech Reminder:


If you have moved all Public Folder Replicas except "OAB Version 3a" and "OAB Version 2" Just wait over night. The replicas will dissapear next day. This

sticks together with RUS which is also done over night. Checks you maintenance Windows also.


Public folder replication issue from exchange 2003 to exchange 2007

Public Folder Replication Troubleshooting